For the complete documentation index, see llms.txt. This page is also available as Markdown.

Partículas en Emotes

Cómo exportar partículas en tus Emotes usando Armature

Los Emotes 2.0 pueden tener sonidos y props, pero ¿sabías que también es posible usar partículas? ¡Pueden ser muy divertidas y añadir ese toque visual extra! Y también pueden acelerar el proceso de animación.

💡 Consejo: Instala el plugin Decentraland Tools Blender. Incluye varias funciones útiles para ayudarte a editar y exportar modelos 3D, wearables y emotes.

Pero como la animación de objetos y los sistemas de partículas no son compatibles con Emotes 2.0, necesitamos convertir estas partículas en una armature (que sí es compatible) para poder agregarlas a los emotes. Usaremos para este proceso un add-on de Blender desarrollado por el equipo de contenido de la Foundation, que puede descargarse desde el enlace de abajo.

Usa el Particles to Bones Addon for Blender ¡para empezar!




El proceso de añadir partículas a tu emote implicará dos pasos; puedes seguir las pautas junto con estos videos:

  • Convertir partículas en armature

Video Preview

  • Fusionar la armature de partículas con la armature del prop

Video Preview

¡Atención!

⚠️ Crear un sistema de partículas no se cubrirá en esta documentación. El objetivo es ayudar a implementarlo en tu emote.

Conversión de partículas en armature

Como se mencionó anteriormente, Emotes 2.0 no admite animación de objetos ni ninguna forma de sistema de partículas. Por eso necesitamos convertir las partículas en una armature.

Para empezar, necesitarás un sistema de partículas funcional y el add-on. El sistema de partículas que se muestra abajo es muy simple; es solo un ejemplo para mostrar cómo funciona el add-on. Asegúrate de que tu sistema de partículas coincida con las animaciones de tu emote para obtener un mejor resultado.



Sistema de partículas simple.

Luego, descarga e instala el add-on. Para hacerlo, ve a Edit > Preferences > Add-ons y haz clic en Install para buscar el archivo en tu computadora.



Haz clic en Edit > Preferences.



Selecciona Add-ons a la derecha y haz clic en Install.

Una vez hecho esto, haz clic en la casilla de verificación para habilitarlo. Una pestaña llamada Converter aparecerá en el lado derecho del Viewport.



Haz clic en la casilla de verificación para habilitar el add-on.



Encontrarás la pestaña Converter a la derecha del Viewport.

Luego, selecciona el objeto, ve a la pestaña Converter, renombra la Output Collection como prefieras, define Start y End Frames y haz clic en Particle System to Armature Converter, como se muestra abajo.



Notarás que se creó una collection en el Outliner, con la armature de partículas. También se creó un clip de animación, al hornear todo el movimiento de cada objeto.



Armature generada por el add-on.



Clip de animación generado por el add-on.

¡Y eso es todo para convertir tus partículas en una armature! Recuerda guardar tu archivo con un nombre diferente (mantén el original como respaldo), lo necesitaremos para el siguiente paso.

¡Atención!

⚠️ Las partículas deben ser el último elemento añadido a tu emote. Cuando el emote esté listo, tendrás la duración exacta de la animación, lo que facilitará sincronizar las partículas con la acción realizada.

Fusionar la Armature de Partículas con la Armature del Prop

Emotes 2.0 solo puede tener dos armatures y dos clips de animación por archivo. Si solo importamos las partículas, terminaremos con tres armatures y tres clips de animación. La forma de arreglarlo es fusionar la armature de partículas con la armature del prop. La razón para fusionarla con el prop y no con la armature del avatar es muy simple: el rig del avatar no puede editarse de ninguna manera añadiendo o eliminando bones. Esto deja a la armature del prop como la única opción.

Fusionar la Armature de Partículas con la Armature del Prop

Emotes 2.0 solo puede tener dos armatures y dos clips de animación por archivo. Si solo importamos las partículas, terminaremos con tres armatures y tres clips de animación. La forma de arreglarlo es fusionar la armature de partículas con la armature del prop. La razón para fusionarla con el prop y no con la armature del avatar es muy simple: el rig del avatar no puede editarse de ninguna manera añadiendo o eliminando bones. Esto deja a la armature del prop como la única opción.

Lo primero que tenemos que hacer es importar o anexar la collection generada por el add-on. Siempre podrías exportar el archivo glb para eso e importarlo en tu archivo de emote. O podrías simplemente anexar la collection, lo cual es mucho más fácil y rápido, yendo a File > Append, busca el archivo de partículas en tu computadora, selecciona la carpeta Collection y elige la collection deseada.



Para anexar una collection, ve a File > Append.



Una vez que busques el archivo de partículas, selecciona la carpeta Collection.



Elige la collection generada por el add-on (que tuviste la oportunidad de renombrar). Particles_Out es solo cómo se renombró para este ejemplo.

Luego, vamos a fusionar las armatures. En Object Mode, selecciona primero la armature de partículas, luego mantén presionado Shift para seleccionar la armature del prop y presiona Ctrl+J para unirlas/fusionarlas, como se muestra abajo.



Una vez que hagas eso, las partículas pueden verse desordenadas, pero no te preocupes, esto forma parte del proceso. Para arreglarlo, selecciona cada objeto de partícula en el Outliner uno por uno, entra en Object Properties (icono cuadrado naranja) y, en Relations, comprueba si el padre es Armature_Prop. Haz esto para todos los objetos de partícula. Esto significa que todos los objetos son hijos de Armature_Prop.



Asegúrate de que Armature_Pop sea el padre de cada objeto de partícula.

Después de hacer eso con todos los objetos de partícula, selecciona el primer objeto de partícula en el Outliner, entra en Modifiers (el icono de la llave inglesa azul) y el campo Object estará vacío. Como esta es la pestaña Modifiers, eso significa que aquí elegirás qué armature controlará el objeto. Así que solo haz clic en Object y selecciona Armature_Prop, y repite esto para todos los objetos de partícula. A medida que lo hagas, notarás que los objetos de partículas vuelven a sus tamaños originales, corrigiendo todo ese desorden creado cuando se fusionaron las armatures.



Selecciona la armature adecuada para controlar los objetos.

Ahora que la armature está correctamente fusionada y configurada, hay un último paso para que esto funcione. Si intentas reproducir la animación, notarás que las partículas no se mueven. Y eso es porque ahora forman parte de Armature_Prop, y la animación que se está reproduciendo por ella es la del prop. ¿Recuerdas que las partículas tenían su propio clip de animación? Lo que tenemos que hacer ahora es copiar los keyframes del clip de animación de partículas y pegarlos en el clip de animación del prop.

Para hacerlo, entra en Pose Mode y en el Outliner, expande Armature_Prop y luego Pose. Selecciona todos los bones que pertenecen a las partículas.



Seleccionando todos los bones de partículas.

Con los bones seleccionados, en el Action Editor, selecciona el clip de animación original de las partículas que tiene todos los keyframes. Selecciona todos los keyframes presionando A, haz clic derecho y copia los keyframes. Luego, selecciona la animación del prop, establece un keyframe en el primer frame y pega los keyframes del clip de animación de partículas.



Copiando frames de la animación de partículas a la animación del prop.

¡Y listo! Guarda el archivo, asegúrate de eliminar el clip de animación original de partículas y exporta como lo harías normalmente.

Si necesitas más información sobre cómo hacerlo, consulta la Exporting sección en la Adding Props and Sounds to your Emotes documentación.

Última actualización